Help
Skip Navigation Links.

Export certificate using Internet Explorer

Cause

You installed your user certificate on your machine but you also need it on another machine (i.e. your laptop).
You are running Windows XP and Internet Explorer on your 2 machines.

Resolution

On the source machine where the certificate is installed:
  • Run Internet Explorer
  • Menu Tools -> Internet Options
  • Select Tab Content -> Click Certificates
  • Select Tab Personal
  • Select your certificate (issued to yourlogin by CERN Trusted Certification Authority)
  • Click Export -> Click Next
  • Select Yes Export the Private Key -> Click Next
  • Select Enable strong protection -> Click Next
  • Type in a password and DO NOT FORGET IT -> Click Next
  • Select a filename (myCert.pfx) to save your certificate to, better save it into your My Documents folder -> Click Next
  • Click Finish
On the target machine where you want to install your certificate:
  • Run Internet Explorer
  • Menu Tools -> Internet Options
  • Select Tab Content -> Click Certificates
  • Select Tab Personal
  • Click Import... -> Click Next
  • Select file (myCert.pfx in your My Documents folder) to import (select file of type *.pfx if file is not shown) -> Click Next
  • Type in the password you selected during Export phase
  • Check Mark this key as exportable -> Click Next
  • Select Personal Store (default) -> Click Next
  • Click Finish
  • Delete the file created during export: myCert.pfx in the My Document folder.
The target machine now has the certificate installed.

IMPORTANT: Delete the pfx file created during export, or anyone stealing this file could use your identity.

Created: 10/12/2015
Last reviewed: 11/2/2015
Tools:
Send the page Send  |  Printable version Print